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1 Introduction

Welcome to SOCET SET. The instructions contained in this manual are designed
to help in the creation of HiRISE DTMs (Data Terrain Models). This is a rather
lengthly process that may take anywhere from 2 days to a week. Table 1 on the
next page provides an outline of the estimated completion times of each step.

When working in polar regions, some of the instructions require alternative or ad-
ditional steps. These will be noted in green throughout the manual.

Hints are rpovided throughout the manual to make your life easier. Hints will be
noted in blue.

1.1 Contacts

Manual Questions Michael Berube (mberube@email.arizona.edu)
DTM Prep Sarah Mattson (smattson@pirl.lpl.arizona.edu)
importCoords2GPF_v2 Aaron Kilgallon (akilgall@email.arizona.edu)
autotriangulation Jon Stephens (stephensj2@email.arizona.edu)

1.2 Available Training Resources

These are some very helpful training resources. The SOCET SET user manual can
be found in the SOCET SET menu or in the directory listed below.

USGS HiRISE Tutorial
/data/DTM_working/USGS_originals

/HiRISE_StereoProcessing_Tutorial_for_SocetSet_December_2009.pdf

SOCET SET User's Manual
/HiRISE/Documents/Training/SOCETSET_user_man.pdf
or, navigate to Socet Set Main Menu > Help > User's Manual
USGS LROC Tutorial
/data/lroc/DTM
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2 Preparation

It is a good idea to look at the jitter plots in HiReport for both observations before
running the prep script. See the appropriate �gures on the following pages to decide
if your jitter is acceptable or unacceptable. If one or both observations need jitter
correction, please email hidip@pirl.lpl.arizona.edu so it can be run through HiJACK.

This script will take about a day to run, so It's best to set it up to run overnight.

Table 1: Estimated Production Time

Production Estimated
Step Completion Time

Preprocess the images Several hours (Run Overnight)

Import the images into SS Less than 1/2 hour

Multi-sensor triangulation About a day

Pairwise rectify (optional) 1/2 hour

Extract terrain Up to 11 hours

Edit terrain ???

Create orthoimages Several hours

Export and produce �nal products 2-4 hours

Total Production Time Minimum 3 days
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Figure 1: Acceptable Jitter
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Figure 2: Unacceptable Jitter (Request Dejittering)
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2.1 Preprocessing images

Steps

1. Using your pirl account, log into a pirl terminal

2. ssh pnode01, pnode02 or pnode03

3. type �isis3�

4. cd /data/DTM_working/Projects

5. screen (this is optional, but recommended)

6. Type the following into the pirl terminal

/data/DTM_working/bin/DTM_prep <Project Name> <Stereo 1 Image ID> <y/n> <Stereo 2 Image ID> <y/n>

The y/n is used to indicate whether or not you intend to request dejittering
for the images.

7. ctrl-A ctrl-D (to detach screen)

8. Use �screen -r� the reattach the window to check progress. This will only work
if you are in the same pnode that you sshed into earlier.

Project Naming Conventions

• You will be typing this name A LOT, so don't make it too compli-
cated. It is also a good idea to write this name down somewhere
for reference.

• A good name starts with a short description, followed by the
latitude and longitude of the image on the Martian surface.

• e.g. Kasei_Valles_2820E_104N describes an image in the Kasei
Valles region with coodinates 282.0 E 10.4 N

• None of your �les should have spaces in their names.
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2.2 Preprocessing dejittered images

If you had your images dejittered, there are some additional steps that you will need
to take before you can move forward with your project. These steps will allow you
to retrieve your dejittered .raw �les as well as their corresponding keywords.lis �les.

Steps

1. cd into the the project directory that was created by DTM_prep1

2. create directories for each of your images titled <image_ID>_dejittered

3. Copy the RED5.balance.cub for each of your images to these dejittered direc-
tories from
/HiRISE/Data/HiStitch/<Mission_Phase>/<ORB_range>/<image_ID>/

4. copy the RED.NOPROJ.cub �le from the link provided through the email you
recieved post dejittering.

5. Type gunzip *.gz to unzip the balance cube and the dejittered cube (�le ending
in NOPROJ.cub)

6. ssh into a pnode and run isis3, then type the following command while in your
dejittered directories,

/data/DTM_working/bin/hidejit2socet_isis560.pl <image_ID>_RED.NOPROJ.cub <image_ID>_RED5.balance.cub

This will output the .raw image and its keywords.lis �le.

1/data/DTM_working/Projects/<project_name>
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2.3 Preprocessing of additional Orthoimages

If you have images to orthorectify in addition to your stereo pairs, then you need to
follow the following steps. If your additional orthoimages are dejittered, you do not
need to complete these steps. Follow the steps under section 2.2 instead.

Steps

1. ssh into a pnode and run isis3

2. cd into /data/DTM_working/Projects

3. Run the following command,

/data/DTM_working/bin/Ortho_prep <Project_name> <image_ID>
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3 Project Setup

This section will walk you through the inital steps necessary to set up your DTM
project. This includes making the necessary directories, setting up your pirl transfer
tool and moving the images to your work environment.

Steps

1. In Windows Explorer, navigate to E: drive and create a project folder within
the SOCET SET images directory,

E:\Socet\images\<Project_name>

2. Make a directory named �isis� within your project folder.

3. Open the SSH Secure File Transfer program and click Quick Connect to es-
tablish a connection to the PIRL system

(Hostname: pirlshell.lpl.arizona.edu, Username: your PIRL username).

4. We will now move the preprocessed images to your work environment.

• Navigate in the left pane to the �isis� folder you created in the previous
step.

• Navigate in the right pane to the pre-processing directory2 on the PIRL
system.

• Drag and drop the .raw and keywords.lis �les over to the left pane. (they
are located in the image ID subdirectories)

• Remember to copy both observations in the stereo pair!

2/data/DTM_working/Projects/ <project name>
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3.1 Socet Set Workstation Setup

Double-click on the SOCET_SET_5.6.0 Exportable icon on the desktop. This will
display the following menu.

Preliminary Steps

1. Click on Project > Create/Edit Project.

2. In the Create/Edit Project dialogue box, click File > New

3. If you are setting up your project on a drive other than C:, just specify the
path in the project data path �eld

(i.e. E:\Socet\data\)

4. Select the Datum to be MARS2000, which is near the bottom of the list.
(Type �m� to get to it more quickly in the drop-down list!)

5. Select the Coordinate System to be Geographic. Even if it already says Geo-
graphic, select it again. If setting up a polar project, select Grid/State Plane,
then from the drop down list, near the bottom, select Mars North or South
Polar Stereographic.

6. (Ignore this step for polar) This opens up a dialog box asking for the approxi-
mate Lat (graphic) and Long (W positive 180) coordinates of your image. Get
these from the stats �le3 generated during the prep stage.

7. Choose Vertical Reference to be Ellipsoid.

8. Enter approximate min and max ground elevation in meters, from your statis-
tics �le2.

3/data/DTM_working/Projects/<project-name>/<project-name>_statistics.lis
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9. Click on the �. . . � button next to Location.

10. Choose Edit Locations. Add your project name and path to the end of the
images directory list in the text �le that opens up, similar to the others in that
�le. The project name and the images directory name should be the same.

11. Save the text �le and go back to select your new project from the list.

12. Click File > Save as, and enter your project name exactly as you wrote it in
the list. Now you will see the Project Path update. Exit.

13. In main SOCET SET menu, select File > Load project. Select your project
from the list and click �OK�. A view window will open up in Graphics only
mode (black screen).

3.2 Importing Images Into SOCET SET

Open a Command Prompt window and type (repeat for each image)

start_socet -single import_pushbroom <project> <fullpath\image.raw> <fullpath\keywords.lis>

Table 2: De�nitions of terms (Importing Images Into SOCET SET)

project SOCET SET project name to import images under (path and

.prj extension is not required)

image.raw This is the .raw �le that you copied from the PIRL server

keywords.lis This is the lis �le with �keywords� in the name located in the

same directory as the .raw �le

HINT: You can drag and drop the �le name from the Windows Explorer address
bar to the Command window to get the full path!
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3.3 Copy MOLA Data To The SOCET SET Workstation

Copy the MOLA DEM .asc �le and the MOLA tracks shape�le (.shp, .shx and .dbf)
created above in the Preprocessing step to the project data directory4, using the
SSH transfer application.

For polar projects, you must �rst convert the MOLA DEM created in the DTM_prep
stage to polar.

1. Open a pirl terminal and ssh into pnode01, pnode02, or pnode03

2. type "isis3"

3. cd into your MOLA_DEM directory in the preprocessing directory5

4. run the following command to convert the .cub �le. (Make sure to type the
name of your MOLA_DEM �le and the name of your output �le into the
designated areas)

map2map from=<MOLA\_DEM.cub> to=<MOLA\_DEM>_PS.cub map=/opt/usgs/data/base/templates/maps/polarstereographic.map

5. After copying the polar stereographic MOLA DEM cube to the Windows work-
station, run this in the command window:

gdal_translate -of AAIGrid <MOLA_DEM_PS.cub> <MOLA_DEM_PS.asc>

The <MOLA_DEM_PS.asc> indicates the name of the desired output �le.

4E:\Socet\data\<project name>\
5/data/DTM_working/Projects/ <project name> /MOLA_DEM
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Figure 3: ArcMap Menu

To convert MOLA TRACKS to polar stereographic:

1. Open ArcMap6, but do not add the shape�le of the tracks

2. For North Polar projects

(a) Click on the �Add Data� button and select your <project_name>_PS.cub
�le

(b) Click on the icon that says ArcToolbox (it should be the button just
below �Help�)

(c) Click Data Management Tools > Projections and Transformations > Fea-
ture > Project

(d) Open �Input Dataset of Feature Class�. Choose the .shp �le from your
data directory. Ignore the warnings, as they will disappear once we are
done in the ArcToolbox.

(e) Open �Input Coordinate System�. Choose Geographic Coordinate Sys-
tems > Solar System > Mars 2000

(f) Name the output �le <project name>_coord_sys and click �OK�

(g) Open �Output Coordinate System�. Select Layers > Polar_stereographic_mars.

(h) Click Apply, wait for progress bar to indicate successfully completed

(i) Import as usual into SS per the instructions below.

6C:\Program Files (x86)\ArcGIS \Desktop 10.2\bin\ArcMap
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3. For South Polar Projects

(a) Click on the icon that says ArcToolbox (it should be the button just
below �Help�)

(b) Click Data Management Tools > Projections and Transformations > Fea-
ture > Project

(c) Open �Input Dataset of Feature Class�. Choose the .shp �le from your
data directory. Ignore the warnings, as they will disappear once we are
done in the ArcToolbox.

(d) Open �Input Coordinate System�. Choose Geographic Coordinate Sys-
tems > Solar System > Mars 2000

(e) Name the output �le <project name>_coord_sys and specify the output
path tho be E:\Socet\data\<project_name> then click �OK�

(f) Open �Output Coordinate System�. Click the �Add Coordinate System�
icon and select �Import�. Choose the MOLA_DEM .cub that you created
in the above step.

(g) Click Apply, wait for progress bar to indicate successfully completed

(h) Import as usual into SS per the instructions below.
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3.4 Import MOLA Data and Tracks

Importing MOLA DTM (DEM)

1. In the main Socet menu, select Preparation > Import > Terrain > ARCGrid

2. Select the MOLA gridded .asc �le you copied into the project data directory
(use _PS.asc for polar projects).

3. Output DTM File: <project_name>_MOLA_DEM (press Enter after typ-
ing the output name)

4. Change Cellsize format to decimal degrees. (This will stay locked for polar)

5. Click Start.

6. Exit when completed successfully.

Importing MOLA Tracks
Make sure you copied the three �les associated with the shape�le you created to the
project data directory in SS.

1. From the main Socet menu, select Preparation > Import > Features > Shape-
�le

2. Right-click in Shape�les box and Add, or File > Open - select the �le that
ends in Z.shp (Z_PS.shp for polar)

3. Enter a name in the output e.g. <project_name>_MOLA_tracks. Press
Return.

4. Press Start to import.

5. When it is complete, File > Exit.

16



3.5 Viewing Images and MOLA Data

It is a good idea to load up the images and the MOLA data to see how things align
at �rst. Most of the time, the MOLA data will be far (hundreds of meters) away
from the HiRISE images, in the Z-direction. That is OK.

Viewing Images

1. Navigate to the SOCET Set main menu and select File > Load Images

2. Click on your left image in the left �eld and on your right image in the right
�eld.

3. Click the �Load� button in the center of the window.

4. You should now see your images in the SOCET Viewer.

5. Select the following options in the SOCET Set Viewer Menu

Figure 4: SOCET Set Viewer Menu

Viewing The MOLA DTM

1. From the main SOCET menu, select Extraction > Terrain > Interactive Edit.

2. Open the MOLA DTM.

3. Click the icon for �Setup DTM Graphics,� change �Dots� to �Editable Con-
tours� and set the contour interval to 25.

4. Click Apply.
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5. Zoom out in the View window till you can see most of the image area. Right-
click in the image area and select �Recenter All�

6. In the ITE window, click the icon that looks like a pencil to draw the contours.

Viewing The MOLA Tracks

1. From the main SOCET menu, select Extraction > Feature > Feature Extrac-
tion

2. Open the MOLA tracks.

3. They will probably draw immediately, or you may have to right-click in the
View window and select �Refresh Graphics�

4. This will erase the contours, but you can redraw them by clicking the pencil
in ITE again.

18



4 Multi-Sensor Triangulation (MST)

About MST
MST re�nes the sensor model. In this step you will create tie points and control
points (Z and XYZ). You can let Socet Set choose tie points automatically (APM),
or you can choose them by hand (IPM). They can always be edited by hand. You
have to select Z and XYZ control points by hand, using the MOLA interpolated
data and the MOLA tracks as guides.

Make sure the viewer has the on-the-�y pairwise recti�cation button selected and
use Limited graphics.

If you just wish to tie the images to each other, then you do not need the MOLA
data. Just run APM as below. However, tying the images to MOLA is considered
to be the most accurate.

BEFORE YOU BEGIN MST, CREATE AN "ORIGINALS" DIREC-
TORY IN THE DATA DIRECTORY IN WHICH TO KEEP COPIES
OF THE ORIGINAL .SUP FILES
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Figure 5: MST Work�ow

4.1 Preparation

1. In the main menu bar, select Preparation > Multi-sensor Triangulation

2. Click on the �. . . � button next to the Triangulation �le box.

3. Create a new �le named <project>_MST (the .atf extension will be added
automatically) at the bottom.

4. Click Save.

5. Click on the Setup button.
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4.2 Setup MST

This opens another dialogue with two blank areas. Beneath the top one, click the
Add button.

• Make sure the dialog reads 1 and click OK.

• Select the �les you want to process. These are the L and R images ending in
.sup. Click OK.

• Select one of the images (the top one) by clicking once on it.

• Now click the Image Data button.

• Set the values to match the image below for the new sensor parameters.

• Check �All Images�

• Click OK again to �nish Setup. Save the triangulation �le and close MST.
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4.3 Relative Solution

• Open the .atf �le in Notepad++

• alt-click and select the red column shown below. Set all of the values to 0.

• Save the .atf �le.

Figure 6: Edited .atf �le

ADJUST_&_SIGMA 0 1000
ADJUST_&_SIGMA 0 1000
ADJUST_&_SIGMA 0 10
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 0 0.1
ADJUST_&_SIGMA 0 0.1
ADJUST_&_SIGMA 0 0.1
ADJUST_&_SIGMA 0 1e-005
ADJUST_&_SIGMA 0 1e-005
ADJUST_&_SIGMA 0 1e-005
ADJUST_&_SIGMA 0 1e-006
ADJUST_&_SIGMA 0 1e-006
ADJUST_&_SIGMA 0 1e-006
ADJUST_&_SIGMA 0 1.1995
IMAGE_FLAG 1
IMAGE_ID 1
IMAGE_SUP ESP_019231_1905_REDmos_hijitreged.sup
IMAGE_IPF ESP_019231_1905_REDmos_hijitreged.ipf
SENSOR USGSAstroLinScanner
INCLUDE_IN_SOLUTION 1
IMG_DATA_1 60.0 0.0
IMG_DATA_2 1000.0 0.0
IMG_DATA_3 0.0 228.6
DEFAULT_FLAG 1
NUM_ADJ_PARMS 16
ADJUST_&_SIGMA 0 1000
ADJUST_&_SIGMA 0 1000
ADJUST_&_SIGMA 1 10
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 1 0.1
ADJUST_&_SIGMA 1 0.1
ADJUST_&_SIGMA 1 0.1
ADJUST_&_SIGMA 1 1e-005
ADJUST_&_SIGMA 1 1e-005
ADJUST_&_SIGMA 1 1e-005
ADJUST_&_SIGMA 1 1e-006
ADJUST_&_SIGMA 1 1e-006
ADJUST_&_SIGMA 1 1e-006
ADJUST_&_SIGMA 0 1.1995
TPP_FILE 3x3.tpp
TRANS_TF_CTRL_IMG 0
etc . . .
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4.4 Absolute Solution

To set up the absolute solution (both/all images move), open your MST .atf �le in
your project data directory and copy and paste the ADJUST_&_SIGMA values
from one of the other images to the top image in the list. You should make sure
that the values are correct (see below) and that the column of 0's is showing 1's and
0's. The 1 corresponds to a checked box in the Setup GUI.

Warning about going back into MST Setup to adjust, or check or uncheck, pa-
rameters: It could cause the values to be corrupted.!

To see if this is what happened to you, use Notepad++, edit the *.atf �le, and
look at the ADJUST_&_SIGMA keywords. If any line looks like the following, it
will cause the error (the erroneous lines are in red)

Figure 7: Error Inducing .atf Values

ADJUST_&_SIGMA 0 1000
ADJUST_&_SIGMA 0 1000
ADJUST_&_SIGMA 1 10
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 1 0.1
ADJUST_&_SIGMA 1 0.1
ADJUST_&_SIGMA 1 0.1
ADJUST_&_SIGMA 1 0
ADJUST_&_SIGMA 1 0
ADJUST_&_SIGMA 1 0
ADJUST_&_SIGMA 1 0
ADJUST_&_SIGMA 1 0
ADJUST_&_SIGMA 1 0
ADJUST_&_SIGMA 0 1.1995
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If this is what you are seeing, replace the ADJUST_&_SIGMA section for each
image with:

Figure 8: Correct .atf Values

ADJUST_&_SIGMA 0 1000
ADJUST_&_SIGMA 0 1000
ADJUST_&_SIGMA 1 10
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 0 1
ADJUST_&_SIGMA 1 0.1
ADJUST_&_SIGMA 1 0.1
ADJUST_&_SIGMA 1 0.1
ADJUST_&_SIGMA 1 1e-005
ADJUST_&_SIGMA 1 1e-005 (5e-006 for dejittered)
ADJUST_&_SIGMA 1 1e-005
ADJUST_&_SIGMA 1 1e-006
ADJUST_&_SIGMA 1 1e-006
ADJUST_&_SIGMA 1 1e-006
ADJUST_&_SIGMA 0 1.1995
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5 Interactive Point Measurement (IPM)

You will create several tie points on the images in this step, improving the overall
quality of overlapping images. It is important that you save frequently during this
process, as IPM is prone to bizarre behavior and crashes.

A short overview

• Create a minimum of 16 tie points

• Add 2 Z-control (relative solution: keep L image parameters unchecked)

• Add XYZ-control (absolute solution: let L image adjust by checking parame-
ters as above)

You will repeat this process several times, so it is important that you follow the
directions accurately.

HINT: Always run Solve on the ORIGINAL .sup �les. Backup your solution several
times during the process and DO NOT DELETE tie/control points. Just uncheck
them!
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5.1 Creating Tie Points

You should create sixteen tie points across your DTM image. All of the tie points
should be spaced out evenly, creating a 4 x 4 grid. See the �gure below for reference.

Steps

• Open MST (From SOCET SET Menu Preparation > Multi-Sensor Triangu-
lation)

• Open Interactive Point Measurement (IPM)

• In IPM, click the Settings button and check the "Auto Img List" radio button.
This preference stays in place once you have turned it on.

• To add a new point, right-click the white space in the point list (top) and click
Add.

� Move to the place in the images you want to put a point.

� Get close to or on the ground. Zoom in to 4X (sometimes 2X is better).

� Really get the 3D cursor as close to the ground as possible. If there
is y-parallax, line up the 3D cursors so they are only separated in the
y-direction.

� Check the lock and measure boxes on the L image

� Move the 3D mouse around until both cursors align (the pain stops!). Do
not use the Z-wheel.

� Either check the Lock and Measure boxes for the R image, or click the
Auto Two button.

� If the correlation is good, and you are sure the point is really on the
ground, click the Lock and Measure boxes for the R image, then click
the Sample button.

• Save IPM frequently in case it crashes.

• Repeat above steps to add more tie points.

• Space out the tie points so that when you zoom out to 8:1, each point is about
half a screen away from the next one.
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Figure 9: Tie Points Example: This is an appropriate arrangement of tie points.
The yellow markers indicate stadard ties, while the red markers represent z-ctrl
points.
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• Save the IPM �le. Close IPM

• Save the triangulation �le. Close MST.

• Copy the original .sup �les into the project data directory.

• Open MST.

• Click Solve. Click Start.

• If the RMS is 0.7 or less, save the solution.

• Save and close MST.

• Reload the images to see the improved solution.

5.2 Creating Z-Control Points

A NOTE about the next two steps: It is important to understand the di�erences
between the MOLA interpolated data (MOLA DEM) and the MOLA tracks, and
the properties of each data set. Features in the contour drawing of the MOLA
interpolated might only approximately align with those in the image. Open both
the interpolated and the tracks at the same time to understand how well they are
matched. Keep in mind when you are using them that the tracks are the standard
of accuracy that the images should match. We have no better information about
absolute elevations for Mars. Each track represents a larger footprint. Also, the
MOLA tracks can have errors themselves. Try to match the topography as close
as possible to the tracks you trust so the elevation values in your model match them.

Zoom out to a scale of 32:1

Steps

1. In MST (Preparation > Multi-Sensor Triangulation > Interactive Point Mea-
surement)

• Open the MOLA tracks, to guide your selection of Z-control points.

• Extraction > Feature > Feature Extraction

• Display the tracks if they do not appear automatically.

• Display the tie points by turning on the icon display in the IPM Settings
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• Select tie points to change to Z-Control points that are near the MOLA
tracks, and are preferably in relatively �at areas.

• Change 2 or 3 of the tie points to Z Cntl points in type. (The points
closer to the corners are a good choice)

• Try to get Z-cntrl at the top, bottom and one in the middle. Pay attention
to topography. The elevation values should correspond to changes in the
images.

• Close the Feature Extraction window.

2. In Interactive edit (Extraction > Terrain > Interactive Edit)

• Start up IPM in MST and open one of the Z-control points you created.

• Back in ITE, open MOLA DTM. You don't have to draw it.

• Bring up Post Editor tool (BE CAREFUL not to move the stealth mouse,
esp. the z-wheel, when doing this process)

• Click grab post, then click again to release

• Note the elevation value displayed in the point editor

3. In IPM

• Select the point that you measured in post editor

• Enter the Z-value from ITE for that point

• Enter 20 in Z accuracy (enter 50 if on a steep slope or far from MOLA
tracks)

• Under Settings, click �copy accuracy to all points� and click �Save�

• Repeat for each Z-control point you created

• Close IPM

4. Close Post Editor

5. Close ITE (no to save changes)

6. Copy the �les from �ORIGINALS� to your project directory and run Solve in
MST.

29



7. Back up your solution using �Backup Orientation� under the USGS Tools in
the Socet Set Menu

Figure 10: Backing Up Your Solution

Backing up your solution is very important, as an unwanted error may
force you to revert to a previous step in your DTM production. You
can either back up your solution automatically using a built in tool, or
manually by copying the necessary �les.

Using the Backup Tool

1. Navigate to the Socet Set Menu and click on USGS Tools ->
Backup Orientation.

2. Click the �Project� button and select your project. (if you do not
see your project

3. The local �eld should update with a �lepath for your backup.
This tool will

4. Click �Backup� and exit the tool.
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Figure 11: Manually Backing Up Your Solution

Alternatively you can backup your solution manually.

1. Start by creating a folder in your project data directory titled
�<project_name>_Backup_#� where the # is the number backup.

2. Manually copy the following �les that folder,

• <image_ID_1>.iop & <image_ID_2>.iop

• <image_ID_1>.ipf & <image_ID_2>.ipf

• <image_ID_1>.sup & <image_ID_2>.sup

• frame_import.report

• GRAPHICS_ONLY.sup

• <project_name>.gpf

• <project_name>_backup.gpf

• <project_name>_MOLA_DEM_tsr.sup

• <project_name>_ngate_tsr.sup

• <project_name>_MST.atf

• <project_name>_MST.ocov

• <project_name>_MST.rep

3. Repeat this each time you wish to make a backup of your solution.
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Figure 12: Running Solve

Always remember to replace the .sup �les in your directory with the
ones from the �ORIGINALS� folder before you solve. Also, always
quit MST before running Solve again. Running Solve multiple times
without quitting MST may cause the error to propagate. Click Solve
and then click start. Make note of the RMS

If the RMS is > 0.7, open the residuals tab. Z-ctrl points are
sorted at the bottom of the list. Look at Ht/Z, it reports error in z
solution. Use this information to determine if your z-ctrl points need
to be modi�ed.
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6 Next Generation Automatic Terrain Extraction

(NGATE)

You will create your DTM in this step. This stage will take several hours to compute
once you start the terrain extraction. It is a good idea to run NGATE in batch mode.

6.1 Generating NGATE

1. Open NGATE from the SOCET SET menu (Extraction > Terrain > Next
Generation Automatic Terrain Extraction)

2. Click File > Create DTM

3. Click the " . . . " button next to the name box. Give your DEM a new name
such as <project_name>_ngate_<#>. Do not type an extension.

4. Select the left and right images you made in the previous step.

5. Under the DTM properties tab:

• Format = Grid.

• Choose the spacing of your x and y posts (1m if images are bin1, 2m if
images are bin2)

• Click �Draw a Polygon�
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Drawing a Polygon

Please refer to the stealth mouse diagram in the appendix
for button numbers. It is helpful to change the cursor to a
Graticule, 1 circle, radius 25.

(a) Start by moving the stealth mouse to the desired starting point
of your polygon.

(b) Make sure the cursor is on the ground and click button 7 to
begin the polygon.

(c) Move to the next corner of the polygon, snap to ground, and
click button 7 again. This will draw a line across the surface of
the images, your �rst polygon side.

(d) Repeat this to draw the rest of the polygon, making sure that
your lines do not cross over the edge of either of the images.

(e) When you are ready to close your polygon, click button 3. This
will turn your polygon from green to red, indicating that it is
complete.

6. Under the NGATE Properties tab:

• Click the �Strategies� button

• Select �ngate_HIRISE_low_contrast.strategy� for your strategy

7. Under the Seed DTM tab:

• OPTIONAL: Use MOLA gridded to seed.

• Warning pops up about setting; change Seed Point to RSET64.The RSET
number is an allowance for how much error is in the seed DTM. The
MOLA interpolated DTM does not have a known error, so choosing the
largest RSET number is safer. (The MOLA interpolated can be edited to
bring it closer to the HiRISE images, particularly areas between tracks,
where the contours deviate from the actual topography.)
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8. Click Save. Now in the main NGATE window you should see the name of your
DTM �le, Strategy �le �lled in.

9. Click START AT, then Add to Queue in the next dialog that pops up, then
OK.

10. Exit the NGATE dialog and run the process in batch mode

Running Batch Mode

(a) open the <user-name>_queue �le located in your batch
directory7

(b) Delete the �rst part of each command line that ends in .set.
Keep everything between the �rst and last double quotes.

(c) If there is just one ngate command to run, copy and paste
everything after the "C: . . . " from the queue.txt �le into the
Command line to run.

(d) If there is more than one ngate command to run, type "call
" at the beginning of each line. Save as a .bat �le. Click the
.bat �le and sit back. Do not log out of the machine. This will
terminate your ngate command. Just SWITCH USER

11. The �rst passes go quickly, with each successive pass taking longer. This
process has been known to take up to 28 hours, so plan on running it at least
overnight.

7 E:\Socet\data\<project-name>\batch_dir
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6.2 Making a Terrain Shaded Relief Map (TSR)

Steps

1. Open Interactive Edit from the SOCET SET Menu (Extraction > Terrain >
Interactive Edit).

2. Open the ngate �le that was generated in the previous step.

3. In the Interactive Terrain Edit menu select Options > Preferences, then select
TSR.

• Set the �le name for the terrain map.

• You can leave the other settings as default, or experiment.

• Under Color, Scale, select Grayscale or RGB.

• Under Method select Fast if Grayscale, and Traditional if RGB.

• Click OK.

4. In the ITE window, click the Draw TSR icon (looks like a mountain). It might
be hard to see the TSR over the images. They are also probably �ipped/not
the same magni�cation.

5. In the main Socet Set menu, go to Preparation > Mini�cation.

6. Select File > Open and choose the .sup �le of the TSR you named in the
previous step. Click Start.

7. When complete, do File > Exit.

8. In the main Socet Set window again, choose File > Load images.

9. Load the TSR you just mini�ed in the left and right windows, and click load.

10. Now you should be able to see the terrain map in the viewer, and zoom in and
out. You do not need the stereo glasses, except to view. There is no depth in
this image.

11. Errors that are not as obvious in the contours, even at 1 m or less, should really
stand out here. Notice the e�ect the sun angle has on highlighting topography.

12. The tsr is already a ti�. Just copy the mini�cation level you want to email or
save in another directory. There is no need to export it again as a ti�.
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7 Autotriangulation

AutoTriangulation automates the triangulation step, �tting a solution to MOLA
data through a series of rotations and translations. The outputs of autoTriangu-
lation are a .png error map showing the initial, a �nal model error and a text �le
containing revised tie/control point coordinates, a weighting map, and a coordinates
list.

7.1 Creating A GeoTIFF

Before you begin autotriangulation, you will need to create a GeoTIFF �le.

1. Start by navigating to the SOCET Set main menu. Select Output > File
Export > Terrain > GeoTIFF

2. Click the . . . next to the �Input DTM File� �eld.

3. Select your newest ngate product and hit enter.

4. Name your output �le <ngate_�lename>_GEOti� and hit enter

5. Click �Start�

7.2 Running Autotriangulation

1. Open a command prompt window and type autotriangulation to see a help
screen. Take note of the required �les listed (.tif, .rep, and .dbf).

(a) .tif = The GEOti� .tif that was created in the above step.

(b) .rep = The most recent autotriangulation report �le.

(c) .dbf = part of the input shape �le (<project_name>.dbf)

2. Up arrow to autoTriangulation. Insert space, then enter the �rst �le path (or-
der does not matter) (Drag-and-drop is often the easiest way of accomplishing
this).

3. Enter the second and third �le paths.
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4. Include any options you'd like to apply.

5. Options: Orbit �ltering is a very commonly used feature. MOLA tracks some-
times disagree with other MOLA tracks (in the case where they overlap) or are
impossibly distant from terrain in good agreement with :other MOLA tracks.
In this case, it is necessary to �lter orbits

6. The proper format for orbit �ltering is :

C:\ Users\user>autoTriangulation <file1> <file2> <file3> -of %d %d %d

where %d is an outlier track orbit number (more than one orbit may be ex-
cluded)

7. The autoTriangulation error map is a very useful tool in diagnosing outlier
tracks, and judging the quality of the revised tie/control point coordinates.

8. The output text �le includes revised latitude, longitude and elevation values
for every tie/control point. These values are used by Socet Set to determine
a new solution. This process has been scripted:

9. In cmd window, cd to C:\scripts. Type "python importCoords2GPF_light.py"
(without quotes) followed by a space. Then enter the project name, followed
by a space, then drag and drop the autotriangulation report �le (.txt �le). The
script will then update the coordinates in IPM to re�ect the autoTriangulation
results.
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8 Creating a MOLA error map

The DTM may be used to create a map that shows quantitatively how well the
MOLA data �ts to the DTM. This information may be used to further re�ne the
triangulation solution in SOCET SET, or to report the uncertainty of the DTM.

8.1 Polar Projects Instructions

1. Make MOLA comparison map in SS using its command line tool dtm_compare.

start\_socet -single dtm\_compare <Project\_name> <MOLA\_DEM> <NGATE\_DTM> MOLA\_compare\_map

Table 3: De�nitions of terms (Creating a MOLA error map)

<Project_name> the name of your project.

<MOLA_DEM> the gridded MOLA DTM (not the tracks!).

<NGATE_DTM> your ngate output DTM.

2. Open the comparison map in ITE

(a) Load the TSR of your NGATE_DTM in the Image loader

(b) Display the MOLA comparison map as Dots

(c) Set the color range from DTM, but then set it so it is in increments of 5,
centered on -5 to +5.

(d) Take a screen capture of the comparison map, and of the color range, to
use as a legend.

3. In the OUTPUT directory in your project data directory, export the �nal
comparison map to ISIS. For example:

start_socet -single dem2isis3 <Project_name> MOLA_compare_map MOLA_compare_map,cub

4. Copy the .raw and.sh �les, as well as the screen captures of the map and legend
over to the Project directory in DTMgen.
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8.2 Non-Polar Projects Instructions

Export Files

1. The DTM must be exported as a GeoTIFF �le to create the map.

(a) In SOCET SET, click Output > File Export > Terrain > GeoTIFF

(b) Click the button next to the �Input DTM File� �eld and select the desired
.dth �le.

(c) Type a name for the output �le in the �Output TIFF File� �eld. Make
it distinctive (e.g. <project>_dtm_geoti�_export).

(d) Press enter. SOCET SET will �ll in the path and �le extension.

(e) Change the �Elevation format� to 16-bit Integer.

(f) Leave �Precision Output� set to None.

(g) Click Start.

2. Export the MOLA tracks as a shape�le

(a) In SOCET SET, click Output > File Export > Features > Shape�le

(b) Click the button next to "Input Feature Database" and select the desired
MOLA data.

(c) Input an "Export Directory". Again, make it distinct.

(d) Press enter. SOCET SET will �ll in the path.

(e) Click Start.
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9 Interactive Point Measurement (PART 2)

9.1 Creating XYZ Ctrl Points Manually

This section is optional. You can view your error map from the previous section to
determine if creating XYZ ctrl points will have a signi�cant e�ect on your accuracy.

Steps

1. From the main SS menu, select Extraction > Feature > Feature Extraction.

• If the tracks are not already loaded, choose File > Open FDB. Then
select the tracks �le you imported earlier.

• Select the icons for Display Features and Autodraw. (Hover over the
toolbar icons to see the names.)

• Refresh the graphics in the viewer to see the tracks.

• Back in the Feature Extraction toolbar, �nd the Edit tool. Click and
hold the mouse to see the tools. Select the white arrow (selection).

The goal here is to create new control points (XYZ-Control) to account for
any shift or rotation between the images and the MOLA tracks.

2. Look at the tracks and/or the MOLA contours (in ITE) to get a sense of the
relationship between MOLA and the HiRISE stereo pair. For instance, what
kind of movement (direction, amount) would it take to line up prominent to-
pographical features, such as crater rims, dune edges, etc.? Whatever the
movement is, it should be consistent across the image. Before adding XYZ-
control, make sure you have made a backup of your current solution. MOLA
tracks are the standard of accuracy for Mars topography. But beware when
you are viewing tracks � some of them have errors. Make sure what you are
looking at makes sense. Spend a little time deciding where to place the XYZ-
Control points.

3. Open the Coordinate Measurement Tool (under Tools in main SS menu bar).

4. Use the coordinate measurement tool to capture the coordinates of the MOLA
track you want to use.
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5. Snap to that track using the Select cursor in Feature Extraction (The select
tool will only snap if you are close close in elevation to the point)

6. In Coordinate measurement, click Reset, then click Capture.

7. Move to the image location where you think that track should be.

8. In Coordinate Measurement, select Option > Move to Point. Leave this dialog
open for now.

9. Restart MST.

10. Open IPM; this always takes you to the �rst point.

• Right-click on the last point and choose Add.

• Name the new point XYZ_#.

• Change type to XYZ-Control.

• Make sure Auto Img List is on in the IPM Settings. They should be
unchecked for both Lock and Measure.

• Use Coordinate Measurement > Options > Move to point.

• Check the Lock and Measure boxes for the LEFT image.

• Use Auto Two or place the cursor on the ground manually.

• Look at the point to verify that it is on the ground. Zoom in if you need
to.

• Click Sample.

• Change the X, Y and Z values to the track you captured with the Coor-
dinate Measurement Tool.

• Set accuracies for all 3 to 5.000.

• If the point is on a steep slope, maybe consider setting the accuracies to
10.

• Save and close IPM window.

• If Feature Extraction was open, quit it, too.

11. In MST, Solve.

• Make sure to copy the original .sup �les before running Solve.
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• Look at RMS

• When you have entered 3 XYZ-control points, there will be values in the
X, Y and Z RMS boxes. These do not have to be small, they are in
meters. Overall RMS is in pixels. It should be <0.7.

• Look at the residuals, and at the report to see where there might be
problems. Remeasure or uncheck bad points.

• If you get some large RMS value, do not save the solution.

• Save and exit MST.

12. Reload images.

13. Open ITE or Feature Extraction to compare new solution to MOLA DEM
and/or tracks. Tracks are more accurate.

• Look to see if making further shifts will improve things.

• Are the tracks following geomorphology?

• At this point, will the time spent to make further adjustments pay o�?

• Can you live with the errors that are present?

14. Repeat above steps, adding XYZ-control points one at a time. Do not delete
points, just uncheck them to not include them in the solution. Fewer XYZ is
better. No more than 4 XYZ-control points is probably ideal.

15. Stop once you are satis�ed by the number of control points.

16. At this point, after checking the solution versus MOLA tracks, re-run NGATE.
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Removing Outlier MOLA Tracks

1. Select a track point in the outlier orbit.

2. Open attributes in feature extraction to get the orbit ID. Get the
orbit number. Leave this open.

3. Open feature retrieval using the hand icon.

4. Open attribute query (the icon with the question mark).

5. Select feature class.

6. Select attribute, then orbit.

7. Click EQUAL, enter the orbit number, press return, then execute
query.

8. In feature retrieval, change action to delete, then click on apply
action.

9. Hopefully, the orbit track will be removed, and save the �le in
feature extraction.
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10 Editing

Focus on areas prioritized by researcher. What are the goals of the DEM? Balance
time spent editing with scienti�c payo�.

General work�ow:

• Look at overall shaded relief image to see glaring errors.

• Print out and annotate areas to be edited. (optional)

• Work on those areas at the 1m per contour level.

• Zoom out and look for large problems

� �Snow angels� or facets

� High areas

� Pits, etc.

10.1 View Contours

Steps

1. In the SOCET SET main menu choose Extraction > Terrain > Interactive
Edit

2. In the ITE menu, choose File > Open DTM.

3. Set the DTM Preferences, either from the Options menu, or from the Setup
DTM Graphics icon. Make sure Setup DTM is selected in the left-hand pane
of the Preferences window! Click Apply for new setting to take e�ect.

4. Select Editable Contours.

5. Zoom in to no less than 2x. Recenter and refresh graphics. Make sure graphics
is set to Limited before drawing 1 m contours. NOTE! BEFORE drawing con-
tours, or any graphics, always click the recenter button (looks like a crosshairs)
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on the view window. Click the refresh button, too. It looks like two arrows in
a circle, to the left of the recenter button. Socet Set will draw the graphics for
the portion of the image visible in the view window. if you move to another
part of the image, and click draw graphics again, it will draw them in the pre-
vious location, unless you have clicked the recenter button. This is especially
important if you were previously zoomed out, and then zoome in.

6. In general, set color to monochrome. Orange is good. Use your own preferences
here.

7. Click the icon that looks like a pencil to draw the contours.

Editing Tips

• Sometimes it can be hard to discern where the cursor is when
editing. It helps to turn o� the graphics by clicking on the drop-
down menu on the View menu bar that says Limited. Choose O�.
If you are drawing a line, turn the graphics back on to Limited,
then accept the line by pressing the 3 button on the stealth mouse.

• Feel free to zoom in and out as necessary to get a clear perspective.

• Don't forget to recenter before drawing graphics again.

• Editable contours probably will not look nice and smooth. The
purpose of editing is not to make all the contours look like a
beautiful map. Use the relief map to get a good feel for how the
DEM is going to work.

• You could spend the rest of your life editing a HiRISE DEM.
Don't spend more time than is necessary to take care of areas
that are of signi�cance. Resist the temptation to edit everything!

• Save your edits periodically.

Table 4: Editing Tools
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10.2 Automated Terrain Edit (ATE)

You might want to follow NGATE with ATE. This is an optional step, but it is
recommended. ATE is designed smooth out the small-scale blockiness that is char-
acteristic of NGATE. It does not always improve things though, so be sure to save
a copy of the NGATE terrain in case you want to revert to that for �nal editing.
This strategy is a one-pass strategy, so it does not take as long as NGATE, which
uses a 7-pass strategy.

Steps

1. Generate the DEM in NGATE. Do any editing if necessary.

2. Open the DTM in ITE and save it as a new DTM, appending _ATE to the
DTM name.

3. Edit the *.dth �le in the new DTM to make it compatible with ATE

(a) Change the ATE_METHOD to ADAPTIVE.

(b) Delete the lines pertaining to ATE_STRATEGIES and ATE_SEED_DTMS
(if a seed DTM was used).

(c) Set MATCH_OPTION to DOUBLE_MATCH. Save.

4. From the main SOCET SET menu, click Extraction > Terrain > Automatic
Extraction

5. open the DTM edited for ATE

6. Click Start

48



11 Color Setup

This section will walk you through the steps necessary to process color for your
images. Keep in mind that you can only import your color after the triangulation
has been �nalized. If UNFILTERED color is unavailable, the script will fail.

Pre-Process Color

Note: There are two versions of the color products in HiColorNorm � COLOR and
UNFILTERED_COLOR. The script (queue job) will look for the UNFILTERED
version �rst, but if it is not there, it will fail. Notify hidip@pirl.arizona.edu to re-
quest that UNFILTERED color be produced for an observation. You might want
to run this is batch mode.

Batch Mode Steps

1. ssh into a pnode and run isis3

2. Make a text �le called �list� that lists the Projects directory and the image ID
on one line (i.e. Fresh_crater_TSL ESP_014011_1315).

3. Call this text list as arguments for the queue job

cat list | xargs -L1 /data/DTM_working/bin/queue_Ortho_prep_COLOR.sh

4. You should receive an email con�rming that the job has completed. To see
the jobs running, type

watch qstat

If the job scheduler does not work for you, you can pre-process color one image at
a time.
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Processing Individual Images

1. Go to the /data/DTM_working/Projects/<Project_name>/ directory. Make
a directory called <image_ID>_COLOR in the project directory.

cd /data/DTM\_working/Projects/<Project\_name>/

mkdir <image_ID>\_COLOR

cd <image\_ID>_COLOR

2. Copy the UNFILTERED_COLOR4 and UNFILTERED_COLOR5 cubes from
the directory

/HiRISE/Data/HiColorNorm/<mission\_phase>/<ORB\_range>/<Image\_ID> to the <image\_ID>\_COLOR

cp /HiRISE/Data/HiColorNorm/ESP/ORB\_023100\_023199/ESP\_023119\_1550/ESP\_023119\_1550\_UNFILTERED\_COLOR4.cub.gz .

3. If necessary type gunzip *.gz. (Most of the UNFILTERED_COLOR cubes
have been gzipped, so they end in .gz).

4. Make a list of these two cubes: ls *.cub > cubelist

5. Run hicolor4socet.pl

/data/DTM_working/bin/hicolor4socet_isis343-4.pl cubelist
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11.1 Import Color to SOCET SET

Steps

1. On the SS workstation, open the ssh transfer app (or whatever you prefer to
connect to the pirl system).

2. Copy the IR, BG and RED.raw �les from the pre-processing folder over to
E:\Socet\images\<Project>\isis\. If you want to make a color sub-directory
in isis, feel free.

3. Write a batch �le to import the color raw �les using the corresponding RED
.sup �les that have already been triangulated in SS.

4. Here is a one-line gawk command that you can use in cygwin to write a batch
�le (check naming convention of RED sup �le):

cd /cygdrive/e/Socet/images/<project\_directory>/isis/

ls *COLOR*.raw | gawk '{print "call start\_socet -single import\_colorHiRISE.exe
<project\_name> "$1" "substr($1,1,15)"\_REDmos\_hijitreged.raw\r"}' > color\_import.bat

5. Run color_import.bat to import the color. (Don't import color into SS until
after you have your �nal solved solution).

6. Import the color one at a time in the Command window with this command:

start_socet -single import_colorHiRISE.exe <project_name> <COLOR_raw> <corresponding_REDmos>.sup

7. Validate that the color imported correctly by viewing the images in the Image
Viewer. Load the REDmos image in the Left eye and then toggle through
loading the BG, IR and RED color images in the Right eye.
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11.2 Making Color Orthophotos

Steps

1. Open one of the most recently created orthophoto set �les in your batch di-
rectory (Socet/data/<project>/batch_dir/), it will end in a .set, then save
as orthophoto_template.set

2. In the project images directory (/cygdrive/e/Socet/images/ <project_name>
/isis), make a list of the color raw �les to make into orthophotos NOTE: If
there is only one bin mode for all your color, you can write it at the same time
you make the list, such as:

3. If All the images are bin 1:

ls *COLOR*.raw | sed s/.raw// | gawk '{print $1 " 1\r"}' > colorlist

4. If All the images are bin 2:

ls *COLOR*.raw | sed s/.raw// | gawk '{print $1 " 2\r"}' > colorlist

5. Else If the batch of color images are mixed in bin size (in cygwin):

ls *COLOR*.raw | sed s/.raw// > colorlist

Example colorlist

The number at the end of each line indicates the bin num-
bers of the image. Make sure that there is nothing else but a 1 or
2 at the end of each line.

ESP_026905_1660_UNFILTERED_COLOR_BG 1
ESP_026905_1660_UNFILTERED_COLOR_IR 1
ESP_026905_1660_UNFILTERED_COLOR_RED 1
ESP_027182_1660_UNFILTERED_COLOR_BG 2
ESP_027182_1660_UNFILTERED_COLOR_IR 2
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6. Move the colorlist into the batch_dir directory, where the orthophoto
template is

7. Bring up a command prompt and cd to the batch directory.

8. Then open up a windows explorer and go into the Local Disk C:\scripts.

9. Type python then drag and drop ColorOrtho_setFileGen_V2.py into your
command prompt and follow the prompts from the script.
Note: you can drag and drop the �les into the cmd prompt instead of typing
them

10. Once the script has �nished you will have one .bat �le called
master_color_orthos.bat, just double click on this �le and it will generate
your color orthos.
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12 Making Orthophotos

Steps

1. First, run calcOrthoBndry in a Windows Command prompt to get the UR
and LL coordinates. <project_DEM> is the newest DTM that you have
made. The easiest way to get these coordinates into the Orthophoto dialogue
is to copy and paste them from the calcOrthoBdry log �le in the project data
directory.

start_socet -single calcOrthoBdry <project> <project_DEM>

2. In the main Socet Set menu, select Products > Orthophoto Generation

3. Select the start tab and choose �Orthophoto�

4. Select the input tab and choose your primary image

(a) Use the solved, but not pairwise recti�ed images' .sup �les (i.e. not the
ones ending in _l or _r).

(b) Select Use DTM(s). Choose the one you want to use and click the arrow
to send it over to the Selected pane.

5. Select the output tab

(a) Enter the LL and UR coordinates returned by calcOrthoBDRY

(b) Choose format to be ti�

(c) Under GSD, enter the value of your pixel size (per the table below). Add
an ending to your output name such as: _1m_o or _25cm_o depending
on the GSD

Table 5: Orthophoto Naming Conventions

Input Stereo Images DTM Post Spacing bin1 Orthos GSD bin2 Orthos GSD

bin1 (Summing=1) 1 m 1 m, 25 cm 1m, 50 cm

bin2 (Summing=2) 2 m 2 m, 25 cm 2m, 50 cm
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6. Under the Options Tab (check the following)

(a) Create World File

(b) Create Ortho Info File

(c) Construct GeoTIFF Tags

(d) Background Color, click box twice to set to black

(e) Leave other boxes unchecked.

(f) Interpolation Method = bilinear

(g) Don't check stereo mate (based on DEM, there may be some applica-
tions).

7. Click Start At, click Add to Queue click OK.

8. Repeat for other pixel scale and other image(s). starting from Input tab
(above).

9. Set up and run orthophoto in batch mode (see �Running Batch Mode� under
the NGATE section)

10. Exit Orthophoto Generation.
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13 Processing Output Products

This is the �nal stage in DTM production. In this step, you will convert the or-
thoimages and prepare the project for post processing.

13.1 Converting Ortho To ISIS Cube

1. Bring up a command prompt

2. Change directory to the project data directory

3. Create an output_products folder if it does not already exist

4. Change directory to go into output_products/

5. Create an ortho2isis3 batch �le. See the table below

6. In an explorer window, go to those .bat �les (in the output_products directory)
and double click to run them.

7. This will output an <isis>.raw and an <isis>_ortho2isis3.sh �le

Using Cygwin to batch export all orthos

Make sure you run this command inside the data directory, this
command will not work in your output_products directory. Run the
following commands,

> cd /cygdrive/e/Socet/data/<project_directory>
> ls *_o.sup | sed 's/.sup//'| gawk '{print "call start_socet -single
ortho2isis3 <Project Name> " $1 " " $1 ".cub\r"}' > ortho2isis.bat
> mv ortho2isis.bat output_products/
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13.2 Convert DTM to ISIS Cube

1. Bring up a command prompt (Windows) or Xterm (Solaris) window

2. Change directory to the project data directory

3. Create an output_products folder if it does not already exist

4. Change directory into output_products.

5. Run dem2isis3 as follows

start_socet -single dem2isis3 <project> <socet\_dem> <isis>.cub [layout\_flag]

Table 6: De�nitions of terms (Converting DTM to ISIS Cube)

<project> SOCET SET project name to export DEM from

<socet_dem> SOCET SET DEM to export

<isis>.cub desired name of standard isis cube

layout_�ag optional �ag to generate lower resolution standard cube for use

in ARCMAP layouts. Enter y or n, default=n

6. This will output an <isis>.raw and an <isis>_dem2isis3.sh �le

13.3 Ready Files For Post Processing

1. Use SSH Secure File Transfer to mount pirlshell.lpl.arizona.edu and navigate
to the path below

2. Create the directory /data/DTM_working/Projects/DTMgen/<project_name>/

• If there are color orthos, make a COLOR subdirectory there7.

3. Copy the .raw and .sh output �les for the DTM and for the Orthos (they are
in the output_products folder) to this directory.

7/DTMgen/<project_name>/COLOR/
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• If there are color orthos, copy their .raw and .sh �les to the COLOR
sub-directory.

• Also please copy the �nal triangulation report from MST (ends in .rep).

• Copy the error map to the DTMgen directory, too.

4. Next, generate cubes from these raw �les.

• On a pnode, navigate to the directory you just made8, make sure that
isis3 is running, and ensure that the regular orthos and the color orthos
are in di�erent folders.

• Run dos2unix *.sh on the .sh �les.

• Run chmod +x *.sh on the shell script (.sh) �les.

• Make a list of the .sh �les to source using ls *.sh > orthoslist

• Source the list using: source orthoslist.

• Delete the .prt �le.

• Change the permissions on the �les by running:

find . -exec chmod 775 {} +; find . -exec chgrp socset {} +

Let Sarah know the �les are there and that they are ready for DTMgen. Update
the wiki table (https://hirise.lpl.arizona.edu/wiki/DTM_Production_at_UA) sta-
tus to "DTMgen". You are done!

8/data/DTM_working/Projects/DTMgen/<project_name>/
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Archive Project (Completed by Sarah Mattson)

This section is to be completed by Sarah Mattson. The designated archive for
HIRISE SOCET SET data, prep data and �nal products is /data/socet_set. This
directory is writable only by members of the group socet_set. If you get a user
account on the workstation, you should be a member of this group. The archive is
readable by anyone.
Create a top-level directory with the name of your project. Then create two sub-
directories: /SS and /Prep
The SS directory contains all of the SOCET SET project data and images. It should
mirror the SOCET SET directory structure as follows:

• SS/data/<Project>.prj

• SS/data/<Project>/<project data �les>

• SS/images/<Project/<project image �les>

• SS/images/<Project>/isis/<project import �les>

Copy (in the SSH transfer application) the Socet Set data and images directories
into the corresponding archive directories that you made (above).
The Prep directory should contain any of the �les generated by the preparation
of the project, which was probably done in your own data directory, not on the
workstation. Try not to duplicate �les that were copied to the workstation for the
project. That just takes up additional space. It is also a good idea to delete all the
mini�cation levels of images created by SOCET SET. Just keep the full resolution
and delete the _2, _4, _8, etc. levels.

• gzip large �les in the SS and Prep directories to conserve space

• gzip *.img,tif,raw,cub

• gzip *.dte,f,p

The last step when you are sure everything is safely archived is to delete the project
from the workstation. Using the Delete Project command in SOCET SET deletes
EVERYTHING. Do not use this option unless you are positive you are �nished (no
more need to edit or reprocess) and that all the �les are properly archived.
You do not need to delete the project from the Location list. This is just a text
�le, and if you ever restore the project from the archive, it will be there ready to load.
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14 Troubleshooting

SOCET SET Crash

1. First of all, if Socet Set crashes on you, record the error, any messages you
got, what you were doing, time, project, and any other information that seems
relevant. This is always very helpful.

2. Once you have quit or cancelled out of Socet Set, in the terminal window,
delete the following three �les:

.proj<username>set file in the User home directory

.mem<username>set and .cur<username>set in the project data directory

3. Restart SOCET SET

4. Reload your project, and the images. Make sure to load the images at the
load point, not the current point.

Images won't load. . .

. . . Due to unknown sensor type
This is probably because the images were imported using an old version of im-
port_pushbroom. In 5.4.1, the sensor type keyword in the .sup �les should say
USGS_Astro_GENERIC_PUSHBROOM.
In 5.5, the sensor type should be GENERIC_PUSHBROOM.
Just delete the USGS_Astro_ part of the keyword in the .sup �les and reload the
images.

Run the following code in cygwin,
ls *COLOR*.sup | xargs -L1 grep -l 'USGSAstro' | xargs -L1 sed -i -e 's/USGSAstro_//'

unix2dos *COLOR*.sup

. . . Due to a message like "can't compute partials"
This can be solved by restoring the original .sup �les and deleting the three memory
�les as above (after quitting SS of course). If you have already created a solution
in MST, you will need to re-run it to update the original .sup �les to the current
solution.
If the images still won't load, reimport them and save the original sup �les again.
Reload the images.
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Misc Problems

• Try to not have too many windows open, or graphics turned on. This has
caused crashes in the past.

• There are some �elds that may not actually accept entered values unless you
hit the Return key.

• APM fails (in Multi-Sensor Triangulation). This is usually a problem that the
ground point �le does not get written. Make sure that this �le is named in
the Setup step of MST.

• NGATE fails to run with error in log that polygons could not be computed.
Try redrawing the NGATE boundary more carefully, avoiding the edge (gratic-
ule diameter 25) and following the terrain more closely.

• NGATE fails on the �rst pass with no error messages: Try redrawing the
boundary more carefully, cutting out any sections on the edge that are dusty
or have issues with �nding the ground.
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Tips

1. When opening SOCET SET applications, they will default open
in the stereo monitor. This is a pain, but unavoidable. To conve-
niently grab the window and move it over to the regular monitor,
right-click on the tab associated with that window/dialog at the
bottom of the regular monitor and select Move. Then you can
just drag with the mouse. Unfortunately, not all of the dialog
windows in SOCET SET will come with a tab, generally only
ones that have their own �le menu items do.

2. Right-click in the Viewer window (anywhere), with the regular
mouse, to quickly access handy graphics tools.

3. (This may not apply in newer versions of SOCET Set.) The
IMAGE_ID in the beginning of the .sup �les is the pre�x to
all the automatically generated control points. To customize
the naming of the control points, edit the default IMAGE_ID
in the .sup �les for each image. By default they are "<OB-
SID>_REDmos_hijitreged" which is very long. You could
shorten it to just the orbit number, or whatever you like.
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Figure 13: Stealth Mouse Button Diagram
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